Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005106Dwarf FortressAdventure Mode -- Townpublic2012-02-15 01:052017-11-25 12:07
ReporterEnigmaticHat 
Assigned ToFootkerchief 
PriorityhighSeverityminorReproducibilityalways
StatusconfirmedResolutionopen 
PlatformPCOSWindows 7OS Version
Product Version0.34.01 
Target VersionFixed in Version 
Summary0005106: Bandits/companions respawn/duplicate in their original location
DescriptionIf you kill an enemy under a town and then return, you will find the same enemy type in exactly the same location, probably standing next to what appears to be their own clone. I was able to find the same group of kobolds (one bowman and one spearman) in exactly the same location multiple times, both by leaving and coming back, and by waiting in the room. I've seen this happen with human bandits in the sewer system and kobolds in an in-town tomb.
Steps To Reproduce1. Find an appropriate enemy in sewers/catacombs.
2. Kill that enemy.
3. Leave and come back, wait, or sleep.
4. Kill that enemy again.
TagsNo tags attached.
Attached Files

- Relationships
related to 0006015resolvedToady One Reclaiming multiple times gradually slows the game down, leather starts to appear 
has duplicate 0005182resolvedFootkerchief Duplicate people in Adventure mode 
has duplicate 0005332resolvedKnight Otu cavern men in the sewers 
has duplicate 0005435resolvedLogical2u Cloned companions recruited at forts 
has duplicate 0006400resolvedFootkerchief Creature and leather duplication on reclaim or revisit 
has duplicate 0004702resolvedFootkerchief Some companions counted twice on [c] list 
has duplicate 0006635resolvedFootkerchief Companions duplicating 
has duplicate 0008301resolvedFootkerchief Swordsman companion somehow duplicated himself after I slept 
has duplicate 0009199resolvedDwarfu Companion human duplicates after sleeping in human fortress 
has duplicate 0008932resolvedDwarfu My companion cloned herself after fast travel 
has duplicate 0009516resolvedDwarfu A NPC has a clone after I invited him to join me 
has duplicate 0009381resolvedDwarfu duplicate companions after traveling from tavern 
has duplicate 0009779resolvedDwarfu Duplicate Companions 
has duplicate 0010159resolvedFootkerchief Duplicate people, person comes back as a double after being killed (original corpse remains) 
related to 0005162acknowledgedFootkerchief Companions spontaneously leave group and can be re-recruited, resulting in duplicate entries in companion list 
related to 0005557new Necromancer adventurer gets buggy quest to re-kill a titan he already killed and reanimated 
related to 0008334new Trolls in goblin sites respawning constantly 
related to 0008480new Companions teleport after moving 
related to 0009133confirmedDwarfu Crash (Duplicate Object Offloaded) upon retiring adventurer (Duplicate Companions) 
related to 0010515acknowledgedDetros Duplicating of companions 

-  Notes
(0019628)
Footkerchief (manager)
2012-02-15 07:05

Reminder sent to: EnigmaticHat

A save would be helpful for this one. http://dffd.wimbli.com/ [^]
(0019722)
EnigmaticHat (reporter)
2012-02-15 17:13

I have a save up: http://dffd.wimbli.com/file.php?id=5523 [^]

I am now absolutely sure the bandits are respawning: I managed to produce three kobold spearman corpses in the same room with the same name.
(0019752)
DarkX2 (reporter)
2012-02-16 00:51

I am also adding a save: http://dffd.wimbli.com/file.php?id=5530 [^]


To verify:
1. Have a look at my kills - you will note that I have killed some bandits twice.
2. Leave the dungeon (Southern door, Southern door, short floor, use the up/down stairs at end of floor to go up, next floor go south and then the stairs up, use south door, use west door, use stairs you are back in castle.)
3.Leave castle, fastravel one square away, return to castle)
4. Enter castle, enter the dungeon, go the way back
5. In the room with some stuff and statues, there should be a new bowman that is the same as one I have already killed (twice I think)
(0019808)
Footkerchief (manager)
2012-02-16 09:42

Goton reports at 0005182 that this can also happen with slain companions.
(0020897)
Jiharo (reporter)
2012-02-29 00:35

Yet another save for 34.04: http://dffd.wimbli.com/file.php?id=5739 [^]
Slain companion "Smenre Jalewrarses" was re-recruited in the same place
(0020951)
Quietust (reporter)
2012-03-01 09:39
edited on: 2012-03-01 10:56

I've gotten this to happen even without them being killed - if I recruit a soldier at a castle, wander far enough away for its initial location to be offloaded (e.g. recruit a guy in the east battlements, then walk to the west battlements), then come back, he's still standing there (despite also being in my party) and will join me a second time.

Taking a look at the internal data structures, each unit appears to be linked to a distinct historical figure - thus, while they all have the same names, they are technically distinct clones of the original person.

(0021247)
malvado (reporter)
2012-03-07 19:32

Having this one as well, in 34.05
Good way to raise fighting skill and kills though.
(0021738)
Goton (reporter)
2012-03-26 06:26

This is still in 34.06, and I hate it A LOT.
(0021775)
NW_Kohaku (reporter)
2012-03-26 19:25

I can fast travel to a castle, hire the first swordsman I see, leave, fast travel one step out then back, re-enter the castle, and hire the exact same swordsman again. He's even in the same spot, and he has the same name, etc.

I have a party made entirely of 5 clones of the same guy.

Basically, when data about a given town/city/whatever tile gets saved about how things have changed since the generated data, character information except for historical characters does not get saved.

Humorously, corpses are saved, so you can have a character kill a bunch of villagers, then come back, and the villagers will be back and standing on top of their own dead bodies. http://www.bay12forums.com/smf/index.php?topic=105470.0 [^]
(0022957)
Goton (reporter)
2012-06-11 09:06

I have a save in 34.11 which has this bug. http://dffd.wimbli.com/file.php?id=6477 [^]
(0028204)
thvaz (reporter)
2014-08-03 02:56

I've played adventurer mode a lot and I haven't seen this happening. I think ti could be marked as fixed in 0.40.01.
(0028226)
Footkerchief (manager)
2014-08-03 10:08

Please reopen this report or PM a manager on the forums if this problem is still present in 0.40.05+.
(0029007)
smjjames (reporter)
2014-08-13 19:28
edited on: 2014-08-13 20:12

I've found a duplication/respawn bug in 40.08 that is happening with Dark Towers. I've noticed it before, but I haven't intentionally attempted to replicate it until now.

The bug is shown in action here: http://dffd.wimbli.com/file.php?id=9389 [^]

Steps:

1. kill the goblin there.

2. go behind the door and wait however long (I waited one hour)

3. go back in

4. kill the goblin, note that the corpses have the same name.

5. Rinse and repeat however many times you want. I made him respawn up to five times.

Not sure if it's all dead units or just some of them.

It might be related to 0007940 in that it has to do with bugs appearing when waiting/sleeping or offloading the site.

Edit: Not sure if dark pits are affected, haven't checked yet. Someone might want to check the forest retreats just to be sure.

Edit: I don't think it's happening with dark pits, but not 100% sure.

(0030209)
Footkerchief (manager)
2014-09-15 19:17

smjjames posted another save at 0008301: http://dffd.wimbli.com/file.php?id=9709 [^]
(0030210)
smjjames (reporter)
2014-09-15 19:48

@footkerchief: ah yeah, I didn't think it was the same bug as this one, but ok.
(0030557)
smjjames (reporter)
2014-10-06 16:45
edited on: 2014-10-06 19:49

I've been observing some strangeness with companions sometimes disappearing and not returning after either going far enough from you or waiting/sleeping on goblin sites, but it's sporadic and sort of random. Also, I'm not sure whether it would count as this bug or not.

I think I've gotten a way to reproduce it, not entirely sure, going to try and get a save.

http://dffd.wimbli.com/file.php?id=9870 [^]

Info is in the save posting.

Edit: it's definetly happening when you get too far away from them.

(0030564)
smjjames (reporter)
2014-10-07 09:42
edited on: 2014-10-07 12:25

Sorry for triple post here, but uh, I think it has just happened a few minutes ago in a 40.13 worldgen fort with an unconscious speardwarf who I accidentially made dodge into the stairwell (he lived, obviously), but it wasn't until I was giving my companions stuff that I realized he was missing.

Going to try to get this replicated.

http://dffd.wimbli.com/file.php?id=9875 [^]

1. Wait or sleep however long. Doing fast travel and moving out of the fort also triggers the bug.

2. Observe that the companion number is now 10 and the axedwarf companion is missing. I used DFhack reveal and the companion is nowhere to be found in the site. It's like the companion vanished into thin air.

I did check with DFhack disabled and it still happens.

Toady One should look into this ASAP since it's a rather severe bug, almost to the point of gamebreaking.

Edit: ARG, I think it just happened again when I tried to move away and fast travel to rescue a drowning companion.

(0030586)
smjjames (reporter)
2014-10-09 13:23

Here's one in 40.13 of elven NPCs respawning in elven sites. Look at the two elven bowyers above my adventurer, and look at details on their names, now look at the corpses they are standing on.

http://dffd.wimbli.com/file.php?id=9887 [^]

There may be others, but this is just the most obvious one that I can see.

(I'm posting this in both 0008334 and here since I don't know where I should put it)
(0030807)
smjjames (reporter)
2014-10-30 21:18

Oof, just lost an unconscious companion in 40.14 in a town when I tried to wait an hour to insta-heal her, probably teleported to wherever I found her or her home site is.
(0030947)
smjjames (reporter)
2014-11-10 10:36
edited on: 2014-11-10 10:37

Happened again in 40.15 in a dark tower when a companion went out of range and did not return or reappear. I have absolutely no idea where they teleported to, home probably.

(0033413)
Dwarfu (manager)
2015-12-04 21:18

Saves from 0008932:
http://dffd.bay12games.com/file.php?id=10789 [^]
https://dl.dropboxusercontent.com/u/5482216/0008932%20bug%20confirmation.rar [^]
(0033416)
Dwarfu (manager)
2015-12-04 21:22

Save from 0006635:
http://dffd.wimbli.com/file.php?id=8768 [^]
(0035262)
Dwarfu (manager)
2016-05-21 18:53

Save from 0009381:
http://dffd.bay12games.com/file.php?id=11509 [^]
(0035263)
mrmagolor (reporter)
2016-05-21 19:20

Here's one for my bug: http://dffd.bay12games.com/file.php?id=12057 [^]
(0036988)
Robsoie (reporter)
2017-11-25 08:04

It is happening in 44.02 too

I had a companion npc named Molcet Tohwotog, he died in battle during an adventure.
After coming back to town the game just respawned him.

Saved game to check the legend mode , the character Molcet Tohwotog is listed twice (born same year) and the respawned version is the last on the historical figure list
http://dffd.bay12games.com/file.php?id=13221 [^]

In adventure mode, you can play as the character "Minaro Catanani" that had this Molcet Tohwotog as companion (in legend mode you can check that Molcet is listed twice too).
(0036990)
thvaz (reporter)
2017-11-25 09:35
edited on: 2017-11-25 09:35

This bug is so aggravating and it should have been fixed many versions ago.

(0036998)
FantasticDorf (reporter)
2017-11-25 12:07

@Quietust, goblin sites are reported to have grossly exaggerated ahistorical populations 0007526 & as @smjjames validifies, very fast respawning of goblins & trolls. Exceeding way past the worldgen set limits that only apply to historical ones 0007547

Do these new clones supplant the marital status of the former historical figure? As younger clones of the same person inheriting existing families may be closer to their spouses age & able to produce more children for longer across their indefinite lifespan.

Goblins also murder each other in world-generation regularly so there would be a catalyst for replacing historical individuals on dark tower sites.

- Issue History
Date Modified Username Field Change
2012-02-15 01:05 EnigmaticHat New Issue
2012-02-15 07:05 Footkerchief Note Added: 0019628
2012-02-15 17:13 EnigmaticHat Note Added: 0019722
2012-02-15 17:17 Footkerchief Summary Enemies under towns "respawn" in same location. => Slain enemies under towns "respawn" in same location.
2012-02-16 00:51 DarkX2 Note Added: 0019752
2012-02-16 09:41 Footkerchief Relationship added has duplicate 0005182
2012-02-16 09:42 Footkerchief Note Added: 0019808
2012-02-16 09:42 Footkerchief Summary Slain enemies under towns "respawn" in same location. => Slain bandits/companions respawn/duplicate in their original location
2012-02-17 09:54 Footkerchief Relationship added related to 0005162
2012-02-19 18:44 Logical2u Relationship added related to 0005320
2012-02-19 19:08 Footkerchief Relationship deleted related to 0005320
2012-02-20 05:19 Knight Otu Relationship added has duplicate 0005332
2012-02-24 10:22 mkiever Issue Monitored: mkiever
2012-02-24 14:25 Logical2u Relationship added has duplicate 0005435
2012-02-29 00:35 Jiharo Note Added: 0020897
2012-03-01 09:39 Quietust Note Added: 0020951
2012-03-01 10:56 Quietust Note Edited: 0020951 View Revisions
2012-03-07 19:32 malvado Note Added: 0021247
2012-03-26 06:27 Goton Note Added: 0021738
2012-03-26 19:25 NW_Kohaku Note Added: 0021775
2012-04-13 12:44 Footkerchief Relationship added related to 0005557
2012-05-25 13:38 Mopsy Issue Monitored: Mopsy
2012-06-11 09:06 Goton Note Added: 0022957
2012-06-11 09:19 Footkerchief Summary Slain bandits/companions respawn/duplicate in their original location => Bandits/companions respawn/duplicate in their original location
2012-06-11 09:19 Footkerchief Issue Monitored: Toady One
2013-12-15 08:10 Footkerchief Tag Attached: Fixed in 0.34.12?
2014-01-03 10:43 Footkerchief Relationship added has duplicate 0006400
2014-01-03 10:43 Footkerchief Relationship added related to 0006015
2014-01-26 10:15 Footkerchief Relationship added has duplicate 0004702
2014-01-27 21:30 Footkerchief Relationship added related to 0003605
2014-01-29 10:40 Footkerchief Relationship deleted related to 0003605
2014-07-07 22:23 Footkerchief Tag Renamed Fixed in 0.34.12? => Fixed in 0.40.01?
2014-07-08 06:43 Footkerchief Relationship added related to 0006635
2014-07-09 07:16 Footkerchief Relationship added related to 0006792
2014-07-11 13:08 Toady One Relationship deleted related to 0006792
2014-07-15 06:16 mkiever Issue End Monitor: mkiever
2014-08-03 02:56 thvaz Note Added: 0028204
2014-08-03 10:08 Footkerchief Note Added: 0028226
2014-08-03 10:08 Footkerchief Status new => resolved
2014-08-03 10:08 Footkerchief Fixed in Version => 0.40.01
2014-08-03 10:08 Footkerchief Resolution open => fixed
2014-08-03 10:08 Footkerchief Assigned To => Toady One
2014-08-13 19:19 Footkerchief Assigned To Toady One => Footkerchief
2014-08-13 19:19 Footkerchief Status resolved => new
2014-08-13 19:28 smjjames Note Added: 0029007
2014-08-13 19:29 smjjames Note Edited: 0029007 View Revisions
2014-08-13 19:31 smjjames Note Edited: 0029007 View Revisions
2014-08-13 20:12 smjjames Note Edited: 0029007 View Revisions
2014-09-15 19:17 Footkerchief Relationship added has duplicate 0008301
2014-09-15 19:17 Footkerchief Note Added: 0030209
2014-09-15 19:17 Footkerchief Status new => confirmed
2014-09-15 19:17 Footkerchief Tag Detached: Fixed in 0.40.01?
2014-09-15 19:48 smjjames Note Added: 0030210
2014-10-06 16:45 smjjames Note Added: 0030557
2014-10-06 17:43 smjjames Note Edited: 0030557 View Revisions
2014-10-06 18:18 smjjames Note Edited: 0030557 View Revisions
2014-10-06 19:49 smjjames Note Edited: 0030557 View Revisions
2014-10-07 09:42 smjjames Note Added: 0030564
2014-10-07 09:53 smjjames Note Edited: 0030564 View Revisions
2014-10-07 10:25 smjjames Note Edited: 0030564 View Revisions
2014-10-07 12:25 smjjames Note Edited: 0030564 View Revisions
2014-10-08 05:54 NekoHatsu Issue Monitored: NekoHatsu
2014-10-09 13:23 smjjames Note Added: 0030586
2014-10-27 19:10 Footkerchief Relationship added related to 0008334
2014-10-27 19:10 Footkerchief Relationship added related to 0008480
2014-10-30 21:18 smjjames Note Added: 0030807
2014-10-31 12:57 lethosor Fixed in Version 0.40.01 =>
2014-11-10 09:49 smjjames Note Added: 0030944
2014-11-10 09:50 smjjames Note Deleted: 0030944
2014-11-10 10:36 smjjames Note Added: 0030947
2014-11-10 10:37 smjjames Note Edited: 0030947 View Revisions
2015-12-03 20:53 Footkerchief Relationship added related to 0009199
2015-12-04 20:32 Dwarfu Relationship added related to 0008932
2015-12-04 20:44 Dwarfu Issue Monitored: Dwarfu
2015-12-04 21:17 Dwarfu Relationship replaced has duplicate 0008932
2015-12-04 21:18 Dwarfu Note Added: 0033413
2015-12-04 21:20 Dwarfu Relationship replaced has duplicate 0009199
2015-12-04 21:22 Dwarfu Relationship replaced has duplicate 0006635
2015-12-04 21:22 Dwarfu Note Added: 0033416
2015-12-04 21:23 Dwarfu Relationship added related to 0009133
2016-05-11 21:18 Dwarfu Relationship added has duplicate 0009516
2016-05-21 18:52 Dwarfu Relationship added has duplicate 0009381
2016-05-21 18:53 Dwarfu Relationship added has duplicate 0009779
2016-05-21 18:53 Dwarfu Note Added: 0035262
2016-05-21 19:20 mrmagolor Note Added: 0035263
2016-08-07 19:13 Loci Resolution fixed => open
2017-03-10 15:54 Footkerchief Relationship added has duplicate 0010159
2017-06-08 18:37 Huntthetroll Issue Monitored: Huntthetroll
2017-08-17 01:06 crowbeard Issue Monitored: crowbeard
2017-11-25 08:04 Robsoie Note Added: 0036988
2017-11-25 09:34 thvaz Issue Monitored: thvaz
2017-11-25 09:35 thvaz Note Added: 0036990
2017-11-25 09:35 thvaz Note Edited: 0036990 View Revisions
2017-11-25 12:07 FantasticDorf Note Added: 0036998
2018-01-28 16:01 Detros Relationship added related to 0010515


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker