Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0008605Dwarf FortressDwarf Mode -- Tradepublic2014-12-06 06:012019-01-24 08:38
ReporterLanina 
Assigned Tolethosor 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusacknowledgedResolutionreopened 
PlatformPCOSWindowsOS VersionVista
Product Version0.40.19 
Target VersionFixed in Version 
Summary0008605: Merchants not leaving
DescriptionFirst autumn, Dwarven caravan arrives. Everything goes fine. After getting the message that the merchants are leaving, they leave the Trade Depot (with still some of their stuff on it) and walk a short distance. Thereafter, they stop and don't move at all. So I now have a bunch of merchants and their animals just standing on my map without doing anything.

After deconstructing the depot, the traders left, but the items that they had left on the depot are now mine.
Steps To ReproduceStart new game
Build Depot
Trade with Dwarven merchants
Wait
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0031281)
lethosor (manager)
2014-12-06 06:09

Are you sure that their path isn't blocked? What does "D" display?
(0031354)
troas (reporter)
2014-12-18 09:26

I had this issue as well. I was working on the outer wall while trading, and managed to make the depot inaccessible after they arrived. After removing enough walls to make the depot accessible the merchants departed.
(0031355)
ptb_ptb (reporter)
2014-12-18 10:04

BTW, it is possible to have a depot show up as 'accessible' when there isn't actually a valid path. The wagons need 3 wide, but they also have problems with sharp turns.
(0038291)
lethosor (manager)
2018-05-08 08:03

Stale, needs a save to reproduce. If someone with this issue in 0.44.10+ can upload a save to http://dffd.bay12games.com/, [^] please PM a manager on the forums to get this report reopened.
(0038625)
Toady One (administrator)
2018-07-21 21:18

theli0ndwarf send me a link to this save from 0.44.12:

http://dffd.bay12games.com/file.php?id=13908 [^]
(0038627)
PatrikLundell (reporter)
2018-07-25 02:40

The merchants in theliOndwarf's save will head for the edge as soon as the trade depot is deconstructed, so the problem can be worked around, although I have no idea WHY the trade depot would lock them in place (observing a merchant with gui/gm-editor indicates it has the trade depot as the idling area and no movement destination before deconstructing the trade depot).
(0039149)
FantasticDorf (reporter)
2019-01-24 08:38

I've had this occur to me, but the objects belonging to the merchant(s) still belongs to them because its only 1/4 of their goods they haven't loaded on/off yet. After stalling in depot crouching on the ground, they overstayed, upon desconstruction they left but the items remain.

Relevant Save - http://dffd.bay12games.com/file.php?id=14210 [^]

I've had nothing but trouble since building a second and third trade depot previously (deconstructed now relevant to other issue reports linked on main save), I have lot of objects i cannot dump, stockpile, use or interact with in the middle of my depot-area, the best i can do is forbid and hide but this problem is reccurring for me, though the elves i mentioned that also got stuck had the sense to leave when due after messing around never unloading either.

- Issue History
Date Modified Username Field Change
2014-12-06 06:01 Lanina New Issue
2014-12-06 06:09 lethosor Note Added: 0031281
2014-12-06 06:09 lethosor Assigned To => lethosor
2014-12-06 06:09 lethosor Status new => needs feedback
2014-12-18 09:26 troas Note Added: 0031354
2014-12-18 10:04 ptb_ptb Note Added: 0031355
2018-05-08 08:03 lethosor Note Added: 0038291
2018-05-08 08:03 lethosor Status needs feedback => resolved
2018-05-08 08:03 lethosor Resolution open => unable to reproduce
2018-07-21 21:18 Toady One Note Added: 0038625
2018-07-24 19:50 lethosor Status resolved => acknowledged
2018-07-24 19:50 lethosor Resolution unable to reproduce => reopened
2018-07-25 02:40 PatrikLundell Note Added: 0038627
2019-01-24 08:38 FantasticDorf Note Added: 0039149


Copyright © 2000 - 2010 MantisBT Group
Powered by Mantis Bugtracker